Commonly we configure Mac with HomeBrew, iTerm2 and Oh My ZSH for installation of command line and other packages. There are existing commands for MacOS X for the works we perform via GUI. Utilizing MacOS X command line software update & disk utility makes performing day to day computer management works easy, fast, informative. We have collected the commands all over the web, of course original source is Apple.
MacOS X Command Line Software Update & Disk Utility Commands
To see all the available commands for Software Update, run :
1 | softwareupdate -h |
To read the manual page for Software Update, run :
---
1 | man softwareupdate |
List of available software updates with the following command :
1 | softwareupdate -l |
It will give output like :
1 2 3 4 5 6 | Software Update Tool Finding available software Software Update found the following new or updated software: * 091-00008-3.3 EPSON Printer Software Update (3.3), 25382K [recommended] |
Install the above example’s update :
1 | sudo softwareupdate -i 091-00008-3.3 |
It will give output like :
1 2 3 4 5 6 | Software Update Tool Downloading EPSON Printer Software Update Downloaded EPSON Printer Software Update Installing EPSON Printer Software Update |
We can install only recommended updates :
1 | sudo softwareupdate -irv |
We can install only update for specific software (example given above) :
1 | sudo softwareupdate -i package-name-version |
We can only ignore one but update all others : -–ignore flag, for example:
1 | sudo softwareupdate --ignore package-name-version |
To read the manual for Disk Utility, run :
1 | man diskutil |
List all :
1 | diskutil list |
You’ll get something like :
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 | /dev/disk0 (internal, physical): #: TYPE NAME SIZE IDENTIFIER 0: GUID_partition_scheme *500.1 GB disk0 1: EFI EFI 209.7 MB disk0s1 2: Apple_CoreStorage Macintosh HD 499.2 GB disk0s2 3: Apple_Boot Recovery HD 650.0 MB disk0s3 /dev/disk1 (internal, virtual): #: TYPE NAME SIZE IDENTIFIER 0: Apple_HFS Macintosh HD +498.9 GB disk1 Logical Volume on disk0s2 ZXCVBNMLKF-XXX-YYYY-AAA-QWERTYUIIOP Unencrypted /dev/disk3 (disk image): #: TYPE NAME SIZE IDENTIFIER 0: GUID_partition_scheme +3.2 GB disk3 1: EFI EFI 209.7 MB disk3s1 2: Apple_HFS SynfigStudio 2.9 GB disk3s2 |
If external device is mounted and needs unmounting run :
1 | sudo diskutil unmountDisk /dev/<number> |
Disk utility can verify volume, repair, check backups etc. We are not showing them as they are less needed and you’ll get them on manual.
Tagged With OSX disk utility commands , macos command line firmware , macload disk utility on startup from command line , mac os cmd command diskutil , mac install software command line , mac install disk command line , mac disk utility command line , mac book utility comand , disk utility mac commans , disk utility commands mac